This project is read-only.


Jul 20, 2010 at 8:21 AM
Edited Jul 20, 2010 at 8:22 AM


can it be, that a dynamic vhd with 17,9 GB (19.309.199.360 bytes) after using VirtualDiskConverter ends in a vmfsdynamic vmdk with 4,00 GB (4.294.967.296 bytes) (exactly 4 GB !) ...

I tried it 3 times, with different versions of virtualdiskconver (0.8, actual), but it ended always in exactly 4 GB.

Is it me or does that sound a bit impossible ...

When I try to DiskDump or NTFSDump ... the tools die ...(VolInfo worked, but it gave a wrong disk length and the first sector of the logical volume was sector 0 ... which sounds unusual too.


Any ideas what I might want to test? Mounting the vmdk with VMware Workstation didn't work.


Ciao Ephraim

Jul 20, 2010 at 8:43 AM
Edited Jul 20, 2010 at 8:49 AM

I love wikipedia :) ... an unsigned integer has the max. of 4.294.967.295, so I think I know what I need to search for.


Ciao Ephraim

Jul 20, 2010 at 10:28 AM

Ken, I think you will need to have a look at this ... I'm to dumb for that code :), I mostly have no idea what it does ....

Anyway, I double checked it with the latest discutils source, when it reaches 4GB filesize, it stops growing, not even one byte.

Just clone your own windows box into a vhd and try to convert that into a vmdk vmfsdynamic, when the vhd is bigger than 4GB you should get the situation as I have it here.

Ciao Ephraim

Jul 21, 2010 at 9:52 PM
There's some performance problems in there as well - for me it's using up way more CPU than it should. I'll take a look. Cheers, Ken