This project is read-only.

Created VHD will not be recognized in VMWare products :(

Nov 6, 2009 at 9:15 AM


I create a VHD with some content and add it to a VMware VMachine. The properties of the VMachine tell me the correct size of the VHD I created. But when I boot the Machine, it tells me, that I have none disk.
Even when I boot from a Windows Install CD, I can't repair or install anything, as it always says I have no disk.

VHD's created with disk2vhd can be used inside of VMWare Machines. So I wonder what the problem could be?

Any hints what I'm doing wrong? The MBR has a correct 55 AA at the end, and I tried to embed a XP MBR Bootcode, same result.
The disk is NTFS (formated with DiscUtils Build 33883).

Ciao Ephraim

Nov 8, 2009 at 5:06 PM

Hi Ephraim,

I've used discutils VHDs quite a bit with VMWare workstation, so this should work.  I'd suggest checking that you've partitioned the disk - as with your other post, may be worth checking out you've followed the steps in the same order as the OSClone sample utility.

Also, worth narrowing down the problem - if you create the VHD, can you then partition it inside a virtual machine, and format a volume?  If so, it's probably not a problem with the VHD itself.

If you create the NTFS partition inside a virtual machine, and format it using DiscUtils, does that work?



Dec 3, 2009 at 1:16 PM

Hi ken,

thanks for your answer. The mistake was, that I formated the PhysicalVolume and not a LogicalVolume. Thanks to OSClone I recognized it, so thanks for the hint!.

Ciao Ephraim